• 欢迎访问VPS岛网站,国外VPS,国内VPS,国外服务器,国内服务器,服务器主机,测评及优惠码,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站 QQ群

源码编译apache 2.4.5 出现的问题

Apache技术 沐木小布丁 85次浏览 已收录 0个评论

1、解决依赖关系

httpd-2.4.5需要较新版本的apr和apr-util,因此需要事先对其进行升级。升级方式有两种,一种是通过源代码编译安装,一种是直接升级rpm包。这里选择使用编译源代码的方式进行

(1) 编译安装apr

# tar xf apr-1.4.6.tar.bz2

# cd apr-1.4.6

# ./configure –prefix=/usr/local/apr

# make && make install

(2) 编译安装apr-util

# tar xf apr-util-1.5.2.tar.bz2

# cd apr-util-1.5.2

# ./configure –prefix=/usr/local/apr-util –with-apr=/usr/local/apr

# make && make install

httpd-2.4.5编译过程也要依赖于pcre-devel软件包,需要事先安装。此软件包系统光盘自带,因此,找到并安装即可。

2、编译安装httpd-2.4.5

首先下载httpd-2.4.5到本地,下载路径为wget http://mirrors.sohu.com/apache/httpd-2.4.5.tar.bz2而后执行如下命令进行编译安装过程:

# tar xf httpd-2.4.4.tar.bz2

# cd httpd-2.4.4

# ./configure –prefix=/usr/local/apache –sysconfdir=/etc/httpd –enable-so –enable-ssl –enable-cgi –enable-rewrite –with-zlib –with-pcre –with-apr=/usr/local/apr –with-apr-util=/usr/local/apr-util –enables-modules=most –enable-mpms-shared=most –with-mpm=event

在编译安装时出现一些错误,

问题一:

  checking whether to enable mod_ssl… configure: error: mod_ssl has been requested but can not be built due to prerequisite failure

百度了下原来没有安装opessl-devel,使用yum安装

#yum -y install opessl-devel openssl 问题即可解决。

问题二:

configure: error: MPM most does not support dynamic loading.

此时将–enbale-mpm-shared改为all即可 

最后make && makeinstall 

完成后启动服务即可进行测试


VPS岛 的文章和资源来自互联网,仅作为参考资料,如果有侵犯版权的资源请尽快联系站长,我们会在24h内删除有争议的资源。丨 转载请注明源码编译apache 2.4.5 出现的问题
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址